IPB

Здравствуйте, гость ( Авторизация | Регистрация )

 
ОтветитьСоздать новую тему
> чем открыть?, php
вано
сообщение 23.09.2011, 19:13
Сообщение #1
Норматив выполнен


Group Icon

Сообщений: 230
Из: бийск

Видели на форуме:
27.07.2014, 21:31



Репутация:   0  


Чем открывать для просмора файлы php ? Браузер не открывает как обычную страницу. Заранее спасибо !
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
shew
сообщение 23.09.2011, 19:32
Сообщение #2
Keyboard Cowboy


Group Icon

Сообщений: 399

Видели на форуме:
17.09.2016, 16:00



Репутация:   0  


Текстовым редактором?


Спасибо сказали:
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
Пионер
сообщение 23.09.2011, 19:33
Сообщение #3
Свояк


Group Icon

Сообщений: 797

Видели на форуме:
2.04.2012, 20:51



Репутация:   1  


notepad++ ? он тебе еще и 'подсветку' сделает.

Сообщение отредактировал Пионер - 23.09.2011, 19:33
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
Def
сообщение 23.09.2011, 19:42
Сообщение #4
Я тут прописан


Group Icon

Сообщений: 1 072
Из: Нск

Видели на форуме:
11.04.2018, 21:32



Репутация:   2  


на опережение - инструкция по установке пхп апач мускул: http://blog.atomsoznanya.ru/sitestroy/217-...-windows-7.html


Спасибо сказали:
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
NorthWood
сообщение 23.09.2011, 19:47
Сообщение #5
Высший разум


Group Icon

Сообщений: 6 279
Из: Бийск

Видели на форуме:
2.11.2015, 19:51



Репутация:   4  


По вопросу же ясно, что в браузере надо открыть.

1. Под Windows - Denwer наверное. Не пробовал сам.
2. Поставить Ubuntu и что-нибудь такое замутить: http://pingvinus.ru/note/apache-php-mysql-phpmyadmin , делал, парился, поправил ручками конфиг, но локальный сайт поднял без внешнего хостинга, под убунтой и нативный апач итд (IMG:style_emoticons/default/smile.gif)
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
вано
сообщение 23.09.2011, 19:52
Сообщение #6
Норматив выполнен


Group Icon

Сообщений: 230
Из: бийск

Видели на форуме:
27.07.2014, 21:31



Репутация:   0  


да что то не чем не открывает! (IMG:style_emoticons/default/sad.gif)
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
themasterkarma
сообщение 23.09.2011, 19:54
Сообщение #7
На форуме отметился


Group Icon

Сообщений: 85

Видели на форуме:
15.10.2012, 13:44



Репутация:   0  


Может, глюкнутый?
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
вано
сообщение 23.09.2011, 20:01
Сообщение #8
Норматив выполнен


Group Icon

Сообщений: 230
Из: бийск

Видели на форуме:
27.07.2014, 21:31



Репутация:   0  


Цитата(themasterkarma @ 23.09.2011, 20:54) *

Может, глюкнутый?

может!а может я (IMG:style_emoticons/default/biggrin.gif)
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
NorthWood
сообщение 10.11.2011, 21:12
Сообщение #9
Высший разум


Group Icon

Сообщений: 6 279
Из: Бийск

Видели на форуме:
2.11.2015, 19:51



Репутация:   4  


Цитата(Def @ 23.09.2011, 20:42) *

на опережение - инструкция по установке пхп апач мускул: http://blog.atomsoznanya.ru/sitestroy/217-...-windows-7.html

Def, а такого мануала не достаточно?
http://www.php.ru/install/

Пользуюсь хостинговым всем, но не очень удобно...
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
Def
сообщение 10.11.2011, 21:27
Сообщение #10
Я тут прописан


Group Icon

Сообщений: 1 072
Из: Нск

Видели на форуме:
11.04.2018, 21:32



Репутация:   2  


Цитата(NorthWood @ 10.11.2011, 22:12) *

Цитата(Def @ 23.09.2011, 20:42) *

на опережение - инструкция по установке пхп апач мускул: http://blog.atomsoznanya.ru/sitestroy/217-...-windows-7.html

Def, а такого мануала не достаточно?
http://www.php.ru/install/
Пользуюсь хостинговым всем, но не очень удобно...

вроде достаточно, по моей ссылке просто конфигам внимания больше уделено. без настройки с папками может быть напутано, например. но точно не знаю, какие сложности могут возникнуть)
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
NorthWood
сообщение 10.11.2011, 23:29
Сообщение #11
Высший разум


Group Icon

Сообщений: 6 279
Из: Бийск

Видели на форуме:
2.11.2015, 19:51



Репутация:   4  


It works!

Последние Apache, PHP, MySQL.
Получилось по ссылке php.ru, конечно, кое-что изменилось, но таки заработало.

Попарился с конфигом Apache, а с пхп спетросянил адски: скачал исходники PHP и пытался их подсунуть апачу (IMG:style_emoticons/default/biggrin.gif)

Вот, все очень просто, оказывается.

Себе на память, может и другим пригодится.

1. Качаем Apache http://httpd.apache.org/
2. Ставим Apache, домен и сервер – localhost.
3. Бесплатный MySQL - версия Community Server, ссылка http://www.mysql.com/downloads/mysql/
4. Установка MySQL все как в инструкции здесь http://www.php.ru/install/
5. http://windows.php.net/download/ выбрал PHP VC9 x86 Thread Safe (2011-Aug-23 12:01:10) INSTALLER. Поставил по умолчанию
6. Проверяем установленный софт, как описано в конце http://www.php.ru/install/

Вроде это все, что нужно

Инсталятор PHP сам подключает PHP к Апачу, я только мешал)

Сообщение отредактировал NorthWood - 10.11.2011, 23:41
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение
Hett
сообщение 13.08.2012, 23:42
Сообщение #12
Мастер в своём деле


Group Icon

Сообщений: 839
Из: Бийск

Видели на форуме:
13.05.2019, 15:34



Репутация:   1  


http://windows.php.net/download/#php-5.3

Цитата
Which version do I choose?

If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP

If you are using PHP with IIS you should use the VC9 versions of PHP

VC6 Versions are compiled with the legacy Visual Studio 6 compiler

VC9 Versions are compiled with the Visual Studio 2008 compiler and have improvements in performance and stability. The VC9 versions require you to have the Microsoft 2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed

Do NOT use VC9 version with apache.org binaries

VC9 versions of Apache can be fetched at Apache Lounge. We use their binaries to build the Apache SAPIs.


(IMG:style_emoticons/default/smile.gif) хотя обычно работает
Пользователь offlineПрофайлОтправить личное сообщение
Вернуться к началу страницы
+Цитировать сообщение

ОтветитьСоздать новую тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

 



PDA version Сейчас: 16.06.2019 - 22:30